Установка драйвера intel в Ubuntu 14.04 и 12.04

Компания Intel обновила инструментарий по установке и обновлению драйверов к своим дискретным графическим ускорителям. Инструментарий представляет из себя программу с графическим интерфейсом, которая в диалоговом режиме поможет пользователю даже с начальной подготовкой установить свежие драйверы для видеокарт intel.

Intel как и AMD и Nvidia регулярно выпускает обновления драйверов для своих видеокарт. С каждым обновлением улучшается производительность, добавляются новые возможности,добавляется поддержка новых видеокарт, а так же исправляются ошибки. Очевидно всегда полезно иметь самый свежий драйвер.

Установка

Драйвера распространяются через специально созданный репозиторий, который необходимо сначала подключить. Первым делом добавляем ключи репозитория:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A902DDA375E52366
wget https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | sudo apt-key add -
wget https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 -O - | sudo apt-key add -

Теперь прописываем адрес репозитория. Для Ubuntu 14.04 выполните в терминале команду:

echo "deb https://download.01.org/gfx/ubuntu/14.04/main/ trusty main" | sudo tee /etc/apt/sources.list.d/intel-graphics.list

Для Ubuntu 12.04 выполните команду:

echo "deb https://download.01.org/gfx/ubuntu/12.04/main/ Ubuntu 12.04" | sudo tee /etc/apt/sources.list.d/intel-graphics.list

После этого можно обновлять список пакетов:

sudo apt-get update

Затем устанавливаем утилиту:

sudo apt-get install intel-linux-graphics-installer

После установки утилита запускается через dash поиском по слову intel

ubuntu intel

Оцените статью

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (Пока оценок нет)
Загрузка...

Посмотрите так же

Читайте так же:  Mesa 17.1 и 17.0.6

Установка драйвера intel в Ubuntu 14.04 и 12.04: 9 комментариев

  • 01.10.2014 в 15:39
    Permalink

    а в чем разница драйвера отсюда и драйвера из ppa ?

    Ответ
    • 01.10.2014 в 17:12
      Permalink

      Вероятно более свежие драйвера от производителя. Во всяком случае так было на момент написания статьи. Наверное сейчас уже и в ppa все хорошо.

      Ответ
  • 21.03.2015 в 16:15
    Permalink

    У меня на 14.04 пишет, что дистрибутив не поддерживается. 🙁
    Checking distribution… Failed

    Ответ
    • 25.03.2015 в 00:34
      Permalink

      И у меня так . Покопался и понял,что инсталятор 1.0.7 уже не поддерживается(или не поддерживает ядро 3.16). 1.0.8 поддерживает только ядро 3.18 .Ждем обновления ядра ,или ручками,а я не хочу,у меня LTS. Короче задрал Intel. Вот тут наглядней-https://01.org/linuxgraphics/downloads

      Ответ
      • 25.03.2015 в 19:28
        Permalink

        Я нашел объяснение причин, но вникать не стал. Говорят на 14.04.1 еще установится, а после уже нет. Мол, в Каноникал что-то с пакетами намудрили.

        Вот объяснение на официальном сайте https://01.org/linuxgraphics/comment/1157#comment-1157

        Ответ
        • 07.04.2015 в 23:37
          Permalink

          Почитал http://help.ubuntu.ru/wiki/%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80_%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE%D0%BA%D0%B0%D1%80%D1%82_intel

          Обновился из PPA добавил пакет libva-intel-vaapi-driver, не фонтан,но небо иземля по сравнению с тем , что было раньше.

          Ответ
          • 08.04.2015 в 09:26
            Permalink

            Этот PPA? ppa:oibaf/graphics-drivers

          • 02.06.2015 в 03:44
            Permalink

            Короче,надоело мучиться,обновился до 15.04. Там в «Обновления приложений» дрова Intel уже лежат по умолчанию, нужно только включить.

Добавить комментарий

Ваш e-mail не будет опубликован.